Glade Plugin Car Kit Status – SwagBucks

Yesterday, a reader, Manu, experience the same issue as I, in that Manu checked on the status of processing the receipt for the Glade PlugIns Car Starter Kit & Refill.

Like me, I went to SwagBucks and MyPoint and instances, the status had disappeared, it longer said “Awaiting Review”.

What is really frustrating is the fact that they did not contact me and they deleted my receipt. Not cool.

I scrolled down to the bottom of the SwagBucks website and clicked Customer Support and click “Submit a Request” and I asked simply about the status of the processing of my receipt that I had submitted for the Glade Plugins.

Almost immediately, I receive a reply asking me to reply to the email confirming that I made the purchase and then immediately after I confirmed, I received an email that they had given me 1,000 points credit!  Then this morning, they gave me another 1,000 points.

I also received the points for MyPoints.

{ 7 comments }

  • Anu February 14, 2018, 13:14

    so they gave you two time 1000 points

    • Ms. B. February 14, 2018, 17:43

      Yes. 🙂

  • Vera February 14, 2018, 13:22

    The offer has reset, so they may have had your previous submit in processing.

    • denise February 14, 2018, 14:27

      I sent my info. to contact support and they said I will have to wait for 32 days before they would do anything!

    • Ms. B. February 14, 2018, 17:43

      Vera, you are probably right.

      • denise February 15, 2018, 18:24

        I received my points today from My Points and Swag Bucks. It looks like My Points credited me twice. I received 1,600 points twice! I will send in the glade pluggins rebate for this new offer and see what happens. This time I remembered to use my coupons.

        • Ms. B. February 15, 2018, 21:16

          Denise, congratulations!!! I went back and checked my account and just like you, I got credited twice for the plugins!!!